Performance Point Dashboard Designer Won’t Launch for a New Installation

We’ve been observing a problem in a few PerformancePoint installations that we’ve done recently. You create a new Business Intelligence Center, and then you want to create a new dashboard. You navigate to the PerformancePoint content library and select the Add new item link. You get the “Loading Dashboard Designer” Ajax prompt, but then nothing happens. If you open up the ribbon, and try to create any of the PerformancePoint items, you see the same behaviour.

If there’s existing PerformancePoint content, there is no problem, but new stuff won’t work. As far as I can tell, the problem appears to be that the SharePoint URL is not yet set. You can access the Server setting by clicking the pearl in the upper left of the designer surface, then clicking the Designer Options button, and then the Server Tab

The trouble is, how can you get Dashboard Designer to launch? We’ve found that although it won’t launch from the PerformancePoint Content library, it will from the Data Connections library if you create a new PerformancePoint data connection. You will however need to use the ribbon to launch it.

First,navigate to the Data Connections library and click on the Documents tab in the ribbon. The ribbon should open up,and then you want to click the New Document dropdown (not the button) and select PerformancePoint data source.

At this point, Dashboard Designer should launch. You should then be able to set the SharePoint URL setting.

We have seen issues with setting up the URL however. Occasionally the following error will be displayed:

You can’t then save the value. Our solution to this problem thus far has been to close designer, repeat the process above, and the value gets set automatically.

Once this is done, you can create new PerformancePoint items from the PerformancePoint content library.

If anyone has any additional insight to this, I’m all ears – I consider this to be a workaround.


  1. Hello John,
    I am running into similar problems when running Dashboard Designer for the first time. The error I am getting is regarding the permission issue: “Access is denied. You do not have access to this SharePoint site”. And the sharepoint site it is referring to, is the root of the site collection and not the site where BI center site is and from where I am trying to run Dashboard Designer. I am pretty confident that I have all permissions in place in order to access the site. Also, the user and unattended service account have db_owner rights in the content database and performance point database. Just to be 100% sure, can you please point out the exact permisions requirements for this to work?

    Thank you

  2. I have a similar issue, but Performance Point Designer is not installed (it””s my understanding that when you first click on it, it should prompt you to install, but it doesn””t). The site is a trusted site.

  3. Fix as per here:

    You need to change an IE setting as follows: Downloads > Automatic Prompting for Downloads should be set to “Enabled” (the site was in my trusted sites zone so I changed the setting for that zone).

    You can also install PowerPoint Designer from the BI home page default template and then mouse-over “Build and Share Reports” and then click on “Start using PerformanceServices” and then “Run the Dashboard Designer”. It should then install.

  4. Hello Bill, I am attempting to create a new dashboard or open an existing Excel SS and get the following error.

    access denied. you do not have permission to connect to this server. I have secure store configured correctly and do’t know what is causing the problem.

  5. Hello , I receive this message when trying to open it and have not found a fix anyewhere.

  6. Hello , I receive this message when trying to open it and have not found a fix anyewhere.

    Access denied. You do have permission to connect to the server.

  7. Michael,
    I ran into this issue recently as well when I as setting up PPoint at a client site. One thing I noticed is that when you try to run it it does not use the credentials that you are logged into the SharePoint site with but your windows credentials that you have logged onto the VM with. Figured this out by logging off my normal admin account and trying one of the site administrators. When you long on with that account you can then run the program from the site but make sure you then run IE as an administrator which will allow the program to run. This is what I had to do in order to get this to “work”.

    Hope this helps.

    Joe Colstad

  8. Hi John!
    Can you please explain what exactly was meant by “At this point, Dashboard Designer should launch. You should then be able to set the SharePoint URL setting.”. How and where to save this setting? And also how the setting, which was specified while working with Data Connections would apply when we launch dashboard designer on PerformancePoint Content library?
    I my environment, when I start dashboard designer for entering new Data Connections everything works fine. And SharePoint URL is correct, there is no need to enter it. However when I try to launch designer to enter a new item in PerformancePoint Content library it would not start. I see the same picture as you described at the beginning of your article.

  9. Check the Security Configuration Wizard. If it has been run this error will occur. I rolled the policy back and the error was gone. Hope this helps.

  10. Yo tengo el problema que cuando especifico el url, me dice:
    la dirección url debe estar en una de las siguientes zonas; local, intranet o de confianza

  11. When i ran into this issue with designer not launching, i started to play around with Browser security settings based on the suggestion to enable “download content”. I found that if i added the site to trusted sites and changed the security level to Medium-low it enabled the necessary settings to allow the active x controls for designer to install. you’ll notice this is the case because another popup window will quickly appear showing its downloading or connecting to something. the windows will go away and in a few seconds dashboard designer should appear. So test by either adding site to trusted sites, and changing security to medium-low, or add to trusted sites and manually change all active x settings to prompt or enable including the option to allow downloads that has already been recommended.

Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Exit mobile version